System was fully unavailable
Resolved
Feb 14 at 04:06pm HST
System has fully recovered now. All setting are changed.
Affected services
Created
Feb 14 at 04:05pm HST
Incident Report — February 15, 2026
Status: Resolved
Duration: ~35 minutes
Severity: Major
Summary
Between 01:25 UTC and 02:00 UTC on February 15, 2026, all LuxCore services were unreachable due to an
unscheduled VM shutdown triggered by Google Cloud Platform host maintenance.
Root Cause
GCP performed scheduled hardware maintenance on the underlying host machine. The VM instance hosting
our production environment had its maintenance policy set to TERMINATE instead of MIGRATE, causing the
instance to be stopped rather than live-migrated to a healthy host. The instance did not restart
automatically as the automaticRestart flag was not enabled.
Timeline (UTC)
- 01:25 — VM terminated by GCP host maintenance event
- 01:28 — Monitoring alerts triggered (HTTP, ICMP unreachable)
- 01:40 — On-call engineer began investigation
- 01:52 — Root cause identified; VM manually restarted via GCP Console
- 01:55 — VM online, Docker services auto-recovering
- 02:00 — All services healthy, HTTPS verified externally
Impact
- Full service outage for 35 minutes
- No data loss
- No in-flight transactions were affected — pending payments were resumed
Affected services